Apple reminds users: old applications will not be compatible with macOS High Sierra

Apple has recently released a technical support document that tells professional users which version of Apple Professional applications can support macOS High Sierra, which will be shut out. Document release date but on August 18, but Apple today sends email alerts to professional users Some versions of Apple Professional apps are not compatible with Apple’s latest desktop operating system.

 

The minimum versions that support macOS High Sierra include Final Cut Pro 10.3.4, Motion 5.3.2, Compressor 4.3.2, Logic Pro X 10.3.1, and MainStage 3.3.

Incompatible applications include Final Cut Studio and Logic Studio, these are 32-bit applications.

Leave a Reply

Your email address will not be published. Required fields are marked *